Tuesday, November 8, 2011

Lotus Notes fixpack in .deb traditionally produces this error:
dpkg -i ibm_lotus_notes_fixpack-8.5.2.i586.deb
dpkg: error processing ibm_lotus_notes_fixpack-8.5.2.i586.deb (--install):
 parsing file '/var/lib/dpkg/tmp.ci/control' near line 2 package 'ibm-lotus-notes-fixpack':
 error in Version string '8.5.2-20110323.0837_FP2': invalid character in revision number
To circumvent this error, unpack the .deb archive with:
  1. dpkg-deb --extract which extracts the files in the package.
  2. dpkg-deb --control which extracts the meta-data.
Edit this metadata (/DEBIAN/controls) and remove the underscore from "_FP2". Then, rebuild the package with  dpkg --build .


No comments:

Post a Comment